欢迎光临! [ 登录 ] [ 注册 ] 多客首页 | 个人中心

MACD顶背离底背离公式指标

Dooker 发表于 2015/11/29 12:20:41 226次阅读 0条评论

详细内容

顶背离底背离.png

以下MACD顶底背离公式在通达信中测试通过。

SHORT:=12;
LONG:=26;
M:=9;
DIFF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIFF,M);
MACD:2*(DIFF-DEA),COLORSTICK,COLOR5454FF;
DD:=C=HHV(C,180);
EE:=DEA<REF(DEA,1) AND REF(DEA<REF(DEA,1),1)=1;
CC:=C>REF(C,1) AND REF(C> REF(C,1),1)=1;
上升背离:(CC AND EE)*DEA,COLOR00FFFF;
顶背离:(DD AND EE AND DEA<HHV(DEA,180))*DEA,STICK,LINETHICK3,COLORGREEN;
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C<REF(C,1) AND REF(C<REF(C,1),1)=1;
下降背离:(LL AND GG)*DEA,COLORMAGENTA;
底背离:(FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,LINETHICK3,COLORRED;
MM:=IF(MACD<0,MACD,0);
JJ:=MM>REF(MM,1);
ZZ:=REF(JJ,1)=1;
介入区:(JJ AND ZZ)*DEA,POINTDOT,COLORRED;{MACD蓝柱缩短---指今日比昨天短} 
STICKLINE(介入区=DEA,DEA,DIFF,3,0),COLORRED;
DRAWTEXT(CROSS(DIFF,DEA ),0,'金叉'),COLORCYAN;
DRAWTEXT(CROSS(DEA,DIFF ),0,'死叉'),COLORGREEN;


分享:

点评评分